eclipse mat woe

java.vendor=Oracle Corporation

BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US

Framework arguments:  -application org.eclipse.mat.api.parse /mnt/share/packrd/java_pid3350.hprof org.eclipse.mat.api:suspectsf

Command-line arguments:  -os linux -ws gtk -arch x86_64 -consolelog -application org.eclipse.mat.api.parse /mnt/share/packrd/java_pid3350.hprof org.eclipse.mat.api:suspectsf

!ENTRY org.eclipse.ui 4 0 2018-03-30 19:12:13.641

!MESSAGE FrameworkEvent ERROR

!STACK 0

java.lang.IllegalStateException: BundleContext is no longer valid

        at org.eclipse.osgi.internal.framework.BundleContextImpl.checkValid(BundleContextImpl.java:983)

        at org.eclipse.osgi.internal.framework.BundleContextImpl.removeBundleListener(BundleContextImpl.java:334)

        at org.eclipse.ui.plugin.AbstractUIPlugin$2.bundleChanged(AbstractUIPlugin.java:620)

        at org.eclipse.osgi.internal.framework.BundleContextImpl.dispatchEvent(BundleContextImpl.java:902)

        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)

        at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

 

meant “I spelled api:suspectsf wrong” (see that f)

Leave a Reply

Your email address will not be published. Required fields are marked *

Time limit is exhausted. Please reload the CAPTCHA.