firefox for os x 10.6.8 snow leopard/lion/mountain lion

It appears that versions 49+ do not supports 10.6.8 (snow leopard) or 10.7 or 10.8 for that matters.

So you’re going to want to go here and download either version 48
or 45 “esr”
https://ftp.mozilla.org/pub/firefox/releases/45.9.0esr/

Leave a Reply

Your email address will not be published. Required fields are marked *

Time limit is exhausted. Please reload the CAPTCHA.