ruby-wmi gem with 1.9

irb(main):001:0> require ‘ruby-wmi’
SyntaxError: C:/installs/ruby19_mingw/lib/ruby/gems/1.9.1/gems/ruby-wmi-0.2.2/lib/ruby-wmi/base.rb:52: syntax error, unexpected ‘:’, expecting keyword_then or ‘,’ or ‘;’ or ‘\n’
when /Invalid class/i : raise InvalidClass

irb(main):001:0> require ‘ruby-wmi’

SyntaxError: C:/installs/ruby19_mingw/lib/ruby/gems/1.9.1/gems/ruby-wmi-0.2.2/lib/ruby-wmi/base.rb:52: syntax error, unexpected ‘:’, expecting keyword_then or ‘,’ or ‘;’ or ‘\n’

when /Invalid class/i : raise InvalidClass

meant “go and swap those :’s for ;’s”

2 thoughts on “ruby-wmi gem with 1.9”

Leave a Reply

Your email address will not be published. Required fields are marked *

Time limit is exhausted. Please reload the CAPTCHA.